Unable to access website after DNS change

Domain: ghazanfarshaheen.com

I hosted it on AWS and set its DNS records on Cloudflare about 36 hours back. I can access the site using VPN but not without it. I’ve even tried clearing the DNS cache via Command Prompt (ipconfig /flushdns) apart from clearing my browser’s cache. I’ve tried using different browsers as well.

Please help!

Looks great to me. What error are you getting when you try to visit the site?

2 Likes

On Firefox Developer Edition:
image.png

On Edge:
image.png

I can confirm, I also checked. Website loads fine at my desktop PC and mobile phone (tested using a mobile LTE network conneciton).

May I ask you to:

  1. Try using different Web browser
  2. Try using a Private Window (Incognito mode)
  3. Try using a VPN connection (if available to you)
  4. Restart your home network router (sometimes it could be the DNS cache at our ISP so we may have to wait for a couple of hours or more for DNS propagation)

Have you set custom IP to your hosts file during the development or some old value was set from before?

2 Likes

Just like @sdayman, it loads for me!

Well, they both seem to be having issues reaching the site, but the fact that it loads for certain browsers only is weird!

1 Like

I did try installing SSL via Putty a year ago. The site was hosted on a different AWS account back then. So it had different DNS. But I’ve deleted those DNS records and this time I’ve used Cloudflare for the SSL (instead of Putty).

How do I check the hosts file? Could anyone please guide me?

Thanks!

You can find the hosts file at C:\Windows\System32\drivers\etc\hosts.
if there is something like x.x.x.x ghazanfarshaheen.com you must delete that line.
If you totally not understand it you can send your file here and we can check it for you

1 Like

A bit strange. I was thinking about you might lock-up yourself somehow, but we can access and see the site normally.

From your screenshots may I ask you to re-check if you are using any extension which might, I do not know for sure how, block the access to your own website?

About the error you get:

What happens if you temporary switch from :orange: to :grey: (DNS-only), or enable the “Pause Cloudflare for this site” option from the Overview tab on Cloudflare dashboard?

Maybe your ISP cache, DNS propagation could took up to 72 hours at some providers (at least one is that like in my country) - a bit frustrating for a website owner (I know).

1 Like

Looks like this was the culprit. Time heals everything but 72 hours was too much time! Haha, it’s fixed now. I can access the site normally.

Thanks for all the support. You guys are amazing!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.