Unable to access Private Network on all WARP devices

I’m in the early stages of testing Cloudflare Zero Trust before I deploy it to my larger organization. For this test set up I have my Zero Trust account setup for one user who is authenticated via Google.

This network has the follow nodes:
Android Cell Phone
Ubuntu Server on Google Cloud
Chromebook
Standard PC

The Android Cell Phone and Chromebook have WARP Client version 6.16 for Android installed and are configured for my team account. The server has cloudflared installed with a private tunnel to the server IP address. The PC has the latest WARP Client installed.

For the test I am hosting a webpage on the Ubuntu Server and the firewall has been figured to block all external network access. Only it’s internal 10.128.0.2 address is configured for port 8080 access. Given that a tunnel has been created to that specific address the assumption is that all WARP Clients should be able to access 10.128.0.2:8080. However what I have found is that all clients with the exception of the Android Phone can access 10.128.0.2:8080. Given this I’m fairly certain the the split tunnel configuration is correct in the Zero Trust Center but I can explain why the Android Phone is unable to access the private IP address.

Anyone have any thoughts as to why this might be?

Have you enabled Proxy? Once enabled it takes a moment to kick in.

Also make sure, if you’re on Include mode, 10.128.0.2 or any CIDR including it should be included, and if you’re on Exclude mode make sure that IP isn’t on the list.

The tunnel is set up for a CIDR of 10.128.0.2/32. The split tunnel is in exclude mode and 10.0.0.0/8 is removed from the list. WARP clients are configured for Gateway with WARP. The Proxy is enabled for TCP and UDP.

I still can access 10.128.0.2:8080 on all WARP enabled devices except for an Android Phone.

Restart the Warp client on the Android device.

I’ve tried that a number of times too.

Things to try

  • ->Advance->Connection Options->Reset security keys
  • Logout and login
  • Show your phone some appreciation and say some nice words
  • Reinstall WARP

Finally figured it out. The exclude list on the Android Phone wasn’t updating to the network settings on the Team webpage. I had to completely remove and reinstall WARP.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.