Unable to access newly created Subdomain

Hi there, I’m trying to create a subdomain for my website nikoheart.com which will have it’s own CMS wordpress content on there but I’m having a hard time in figuring out how to get everything setup as I’m unable to even access the site to start working on things.
Trying to access the sub-domain brings back: DNS_PROBE_FINISHED_NXDOMAIN

I’ve recently added two A records for creatordeck and www.creatordeck to the IP address of the host

and Hostgator also has the same Zone records for the subdomain also

So I’m unsure as of what to do next, any help would be immensely appreciated

EDIT: I did notice that my SSL certificates for the website is still pending probably after creating the subdomain, I wonder if this is a contribution toward the the inability of accessing?
Screenshot 2021-07-09 143456

Hi @Nikoheart,

I suspect the error is cached on your end as it works OK for me.

$ dig A creatordeck.nikoheart.com +short
$ curl -I https://creatordeck.nikoheart.com
HTTP/2 301
date: Fri, 09 Jul 2021 13:44:43 GMT
cache-control: max-age=3600
expires: Fri, 09 Jul 2021 14:44:43 GMT
location: https://www.nikoheart.com/creatordeck
cf-request-id: 0b2d1c81a800002b591d301000000001
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v2?s=g3Tu4Y4YAYu3ZMAkNCVYoOEJr4h6Pp%2BHICTHUEKiahgDZvo1yLDGe7cYLTuDtCR9YmiZuTYvzqMofSOE9ugZ5PFqJlUOAynd6P0pVIKzVVorCgQq2mcpjq%2BFG21AgHTSYSTtdSfQKIAikg6nFRA%2FopbjWg%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 66c1fd15da2a2b59-FRA
alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400, h3=":443"; ma=86400

It redirects to https://www.nikoheart.com/creatordeck for me.

That shouldn’t affect rhe DNS issue, but you should make sure that you do have a valid certificate on your server and that your SSL/TLS mode in Cloudflare is Full (Strict).

It finally did at least a thing after some time, now it would be a case of not making it redirect to nikoheart.com/creatordeck and to creatordeck.nikoheart.com

Any suggestions for what to do here?

EDIT: I’m turning off the Page Rule I had set to 301 redirect to that page in question, lets see what happens

Ok update provided!
After discussion with Hostgator, all I had to do was change the SSL in Cloudflare from Full to Flexible
If there’s another solution to be able to turn it back to Full, then let me know, but for now, this works solidly

That’s a terrible Idea, unfortunately! That means the connection between Cloudflare and your server is unencrypted. All you need to set that to Full (Strict) is for your SSL on your server to be valid, which it seems Hostgator can handle.

OK, I’ve changed that, now I’m receiving Error 526: Invalid SSL certificate

That means there is a problem with the certificate on Hostgator’s end. They may be able to fix this with everything as it is, or you could pause Cloudflare (Bottom right under Advanced Actions) do you connect straight to your server and make sure the site is working with HTTPS before re-enabling it.

OK it’s paused, and once again, still the same Error 526

It does seem like it’s still trying to connect to Cloudflare, even with Cloudflare being paused

It can take about 5 minutes to take effect and you may have the Cloudflare DNS values cached on your end.

Will keep an eye on this, I always make sure to check these updates on incognito, no cache, no pain :joy:

That will eliminate the browser cache, but unfortunately not the DNS cache on your device/router.

There is some info on clearing the DNS cache in this article:

It won’t be as easy to reset the router but if a computer restart was enacted that would help yeah?

OK, I checked from my phone, it was able to go directly to the page

1 Like

That may do it if it’s cached on the device, but is probably unnecessary. You can flush the DNS cache in a few ways, depending on your OS.




So after flushing my DNS, I’m provided with a 404 error on the PC, but on my phone, i’m getting the coming soon page
So it’s possible the https isn’t working but the http currently is
Yep, can confirm http is working for the url

Oh, I think I see the issue now. You have a valid certificate on your server for these hostnames:


As creatordeck.nikoheart.com is not on there, you see the 526. Can you get that hostname added to the cert at Hostgator? I would recommend leaving Cloudflare paused until you confirm that’s working on HTTPS and then re-enable it.

Ok I think I found it, it was the SSL/TLS Status of Hostgator, there quite a few other SSL’s that weren’t active, so I’m seeing If I can activate them now. It’s enacting the AutoSSL right now
And NICE, I already see AutoSSL validated the domain for creatordeck.nikoheart.com and www.creatoredeck.nikoheart.com

Gonna reply here again as post limit, but that’s completely worked!!!

I have seen a few prior issues that has ascertained to this similar issue, and it’s a great resolve that we’ve figured out.


For anyone else looking at this post wanting to use Hostgator with Cloudflare and making a subdomain with a CMS system on the subdomain, make it with Cloudflare paused, go into the SSL/TLS Status, tick all check boxes then enact the AutoSSL. Then just re-enable Cloudflare (change to Full (Strict) for the option setting)!

Big shouts to domjh for being amazing and helpful!

I have never used Hostgator, the docs seem to suggest it should be automatic when you add a subdomain, but that doesn’t seem to be the case.

My guess would that it will be under SSL Management, or something similar, in your panel. Or perhaps in the same place as you added the subdomain there? I’m not really too sure and you may need to ask their support if you can’t find it.

Actually, looks like it just got issued → crt.sh | 4837284179

That subdomain works over HTTPS for me now, so hopefully you can re-enable Cloudflare, check the mode is Full (Strict) and you’re good to go!

1 Like