Unable to access localhost via Cloudflare ZeroTrust tunnels

Reposting in the correct group…

I purchased the domain solarisai[dot]com from GoDadday and then changed nameservers to Cloudflare recently. The transfer was successful and I received an email from Cloudflare saying solarisai.com is active in Cloudflare. Thereafter, I tried to create a tunnel in ZeroTrust with Cloudflared on a Windows x64 bit machine for testing purposes. I tried with the public hostname test.solarisai.com that points to my local host which is http://localhost/ or http://127.0.0.1/. However, the public hostname does not seems to redirect to localhost and instead gives a DNS_PROBE_FINISHED_NXDOMAIN error.

Any help on fixing this issue will be greatly appreciated.

Thanks in advance.

  • DNS records are given below.

The error message that appears is given below.

Resolves fine for me. Might try clearing your DNS cache.

Thanks for your suggestion. I tried in Windows cmd with ipconfig/flushdns. However, the issue is still there.

Just to give an update…

Initially, I was experiencing this issue when connected to an institutional network (a university). However, when I changed my network to cellular (mobile internet), test.solarisai.com redirects to /localhost as expected.

Does anyone know the reason for that? The issue is similar might be similar to cloudflare-cdn-not-working-on-some-networks.

I am using a FREE version of Cloudflare and not sure whether it is causing the problem. I would like to upgrade to Cloudflare PRO (paid version) if I am certain that the issue will resolve after the upgrade.

Your ideas/suggestions are highly appreciated.

Thanks in advance.

Thi

At the end, this works. Thanks for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.