Unable send or receive email from webmail using gmail

I was able send and receive email from webmail using my gmail account before configuring cloudflare to my website. Now I am not able to do that now. The webmail is functional and can be used if i am using it through horde or roundcube.

But in the gmail settings it showed “Connection Error. Mail from this account has not been retrieved since Apr 17” when I checked if there is any error.
And now it shows “Your other email provider is responding too slowly. Please try again later, or contact the administrator of your other domain for further information” or “Couldn’t reach server. Please double-check the server and port number” when i tried to add the webmail account after removing it.

This is the image of my DNS management:

I followed the steps in this link: Troubleshooting Email Delivery Issues when using Cloudflare.

Please help. Thank you in advance!

IMAP and POP3 also need to be set to :grey:.

Still shows “Couldn’t reach server. Please double-check the server and port number” when I try to add the webmail account to my gmail account after I set IMAP and POP3 to :grey:

It may take some time to update on your device.

1 Like

It is sitll is not working. And shows the same message

What settings are you using for the account in Gmail? Can you take a screenshot?

i was adding webmail to my gmail account to send email as my webmail account through my gmail.


Did you ask for this screenshot?

That’s the wrong SMTP server. You’ll need to use smtp.omnidevelo.com.

I just tried using smtp.omnidevelo.com and it show “Authentication failed. Please check your username/password” but the username and password are both correct

It’s possible the username is contact rather than [email protected]. We have no way of knowing how your server is configured; you’ll need to contact your hosting provider for assistance if you’re unable to resolve it.

While we’re at it, though, you should double check the IMAP or POP3 settings. You’ll need to ensure that the server for whichever you’re using is imap.omnidevelo.com or pop3.omnidevelo.com; omnidevelo.com won’t work, since that’s proxied through Cloudflare, and Cloudflare mostly only proxies HTTP(S) traffic.

Thank you for responding quickly. I checked my mail client settings and the username and and password is correct. I can login use my webmail by going to omnidevelo.com/webmail which redirects me to login page.
And i was using the mail from my gmail account before I configured my website with cloudflare. My DNS settings of cloudflare is:

While the issue might not have manifested until you switched to Cloudflare, this isn’t actually a Cloudflare issue. Your SMTP server was incorrect before; it happened to work because the A record for both domains was the same, but that’s no longer the case. The SMTP server setting was fixed, but now you’re receiving an authentication error; unlike with the server setting, nobody on these forums has any way to help you troubleshoot that, unfortunately.

Your hosting provider is your best bet–they’ll be familiar with the software and will know the common caveats. It’s possible the webmail login and SMTP login aren’t the same; it depends on how everything’s been configured on their end. They will likely need to talk you through reviewing the logs to determine the cause of the authentication issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.