Umleitungsfehler

Hallo, meine Website ist wahrscheinlich bereits seit zwei Wochen nicht mehr erreichbar. Vor zwei Wochen habe ich von Google folgende Mail bekommen, die ich leider nicht weiter beachtet habe:


Neuer Grund dafür, dass Seiten nicht indexiert werden
Die Search Console hat festgestellt, dass einige Seiten auf Ihrer Website aus folgendem neuen Grund nicht indexiert werden:
Umleitungsfehler
Sollte dieser Grund nicht von Ihnen beabsichtigt sein, empfehlen wir Ihnen, das zugehörige Problem zu beheben, damit Seiten indexiert werden und auf Google erscheinen.

Gestern wollte ich die Website aufrufen und habe im Browser folgende Fehlermeldung bekommen:


Fehler: Umleitungsfehler
Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet
werden kann.
Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder
abgelehnt werden.

Ich habe dann den Support von meinem Webhost Provider kontaktiert. Die konnten mir leider nicht helfen. Irgendwann bin ich dann darauf gekommen, dass meine Cloudflare-Konfiguration für das Problem verantwortlich sein könnte.

Wenn ich Cloudflare deaktiviere, komme ich auch wieder auf meine Seite. Allerdings mit der zu bestätigenden Warnung, dass die Seite nicht sicher wäre.

Ich habe daraufhin hier im Support nach eine Lösung gesucht. Das einzige was ich gefunden habe ist, dass ich den SSL-Modus in den SSL/TLS-Einstellungen auf Vollständig(Strikt) stellen sollte. Das hat aber leider nicht geholfen.

Was könnte ich denn noch ausprobieren? Über Hilfe würde ich mich freuen.
LG

What is the website?

www.thaisabai.de

You have both a redirect from https://www.thaisabai.de to http://www.thaisabai.de AND a redirect from http://www.thaisabai.de to https://www.thaisabai.de, hence the circular redirects.

https://cf.sjr.org.uk/tools/check?cdf65908aa5a4ed5b5b54c455a3254ff#connection-server

(This isn’t the “SSL/TLS is Flexible” issue as we wouldn’t see the http step externally, keep with Full Strict).

If you have an https->http redirect set in Cloudflare or on your origin, you should remove it.

1 Like

Thanks for your help. I checked everything and can’t find any redirect to http. Everything is set to https.

It seems you have turned off Universal SSL and set SSL/TLS to “Flexible”…
https://cf.sjr.org.uk/tools/check?a5ce6f5822d34d579be88fdeda1b3176#connection-worker
so HTTPS access to your site is now broken.

You will need to re-enable Universal SSL and switch to “Full (strict)” for things to get back to where they were so the redirect issue can be fixed.

If you temporarily pause Cloudflare, we can check direct to your origin server to see if there’s any issue there.

1 Like

Universal SSL was turned off (I enabled it again) and SSL/TLS was set to Full(Strict). I will pause Cloudflare now. Thanks for your help!

OK, the origin seems ok. You can unpause Cloudflare now and see what happens.

curl -I http://www.thaisabai.de
HTTP/1.1 200 OK
Date: Fri, 29 Dec 2023 10:59:29 GMT
Server: Apache
Upgrade: h2,h2c
Connection: Upgrade
Cache-Control: max-age=0
Expires: Fri, 29 Dec 2023 10:59:29 GMT
Vary: Accept-Encoding,User-Agent
Content-Type: text/html

curl -I https://www.thaisabai.de
HTTP/2 200
cache-control: max-age=0
expires: Fri, 29 Dec 2023 10:59:31 GMT
vary: Accept-Encoding,User-Agent
content-type: text/html
date: Fri, 29 Dec 2023 10:59:31 GMT
server: Apache
2 Likes

I think it’s working now. :slight_smile: Thank you so much for your help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.