UDP Traffic not working

Hello,

I have a wireguard VPN server running on my pi at home. I also have my own domain that I want to use to connect to it. I already used a DDNS (DuckDNS) to handle my dynamic IP but it seems that I can’t connect to it via the domain I set up in Cloudflare.
When I use the domain from duckdns it works, but not via my actual domain that refers to the duckdns domain. So my question is how can I fix it, or is it even fixable?
For clarity this is the situation:
Via my domain (XXXXXXXXX.com) - not working
Via duckDNS (XXXXXXX.duckdns.org) - working

I forgot to mention I use a CNAME record for my domain to point to the duckdns domain. I have tested two versions of it. With the base domain only: (XXXXX.com) and with a sub domain: (YYYY.XXXXX.com) both do not work

Is the record proxied or not? Is it :orange: or :grey: in the DNS settings?

its proxied.

And how do you want to connect to it? And more importantly, what ports do you want use?

what I would like is to use my domain to connect to my vpn. It uses UDP port 51820.

Oh sorry, didn’t realise you already mentioned it. Cloudflare doesn’t support that port, and doesn’t support non-HTTP(S) services in the base product. You need to unproxy it to make it work.

Okay. I couldn’t find anything on it so I assumed I could. thx

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.