UDP is not working for RDP through cloudflare tunnel

Hey, I have a computer with cloudflared setup and running and then I have the warp client setup on another computer and I want to connect to the other computer through RDP. I am able to get it working using the following setup:

  • warp client set to Gateway with WARP mode
  • network settings in zero trust has TCP and UDP enabled
  • my local ip subnet removed from the exclude list
  • confirmed cloudflared is running quic mode (should allow UDP)

But with all this I only able to connect using TCP. The connection bar in remote desktop does not show “UDP enabled” and the performance isn’t as good.

I read that Cloudflare tunnel and warp client should support UDP now so I am wondering if this is true and if so what I am i doing wrong that is causing my remote desktop to not work over UDP?

1 Like

Im wondering the same. I didn’t manage to get this working either. UDP performance is much better when using RDP.

Same here :frowning: