TXT records are not resolving

Hello,
I have simple problem with name resolving. For authentication reson applications ask to add TXT records. I added one a week ago and still it is not visible for DNS chcecker. My config:

A | zaprasza.online | 212.127.94.64 | Auto | DNS only
CNAME | www | zaprasza.online | Auto | DNS only
TXT | _acme-challenge | w6dyq3jKgfUWQfdEGgWuUTpc5fgn36FrFqSNwiEBSpY | 15 min | DNS only
TXT | _cloudlets | 1234567890 | 15 min | DNS only
TXT | _test1 | test1-0001 | Auto | DNS only

I will be grateful for a hint of what I am doing wrong!

Which one is not being detected?

 % dig +short TXT  _test1.zaprasza.online
 _test1.zaprasza.online.	300	IN	TXT	"test1-0001"

Hello,
acme-challenge

Looks OK to me. Is the name correct?

 ;; QUESTION SECTION:
 ;_acme-challenge.zaprasza.online. IN	TXT
 
 ;; ANSWER SECTION:
 _acme-challenge.zaprasza.online. 900 IN	TXT	"w6dyq3jKgfUWQfdEGgWuUTpc5fgn36FrFqSNwiEBSpY"

Yes, correct. So why most of DNS checkers dosn’t see this? For example:

Have you enabled DNSSEC on the domain and if so, does the DNSSEC settings at the registrar match what Cloudflare provided?

I had something similar to this before when the DNSSEC digest was incorrect (the TXT record not showing)

No. Thank you for the hint! I will add DNSSEC and test again.

Hi,

DNS Checker works just fine, you didn’t specify the name of the record. See this one here and it’ll show the contents.

Where are you getting errors that the records are not set/available?

Good point.
I’m trying to install Let’s encrypt in PLESK. It doesn’t want to act. Main problem was with resolving TXT in domain name.

Thank you very much for your help! It looks like DNSSEC solved my problems, because now I finished “Let’s encrypt” installation for “zaprasza.online” at once.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.