TXT record / SPF not working

I’m setting up a Dubsado account and need to connect it to my email address (which is associated with my Squarespace domain, for which I use Clourflare).

Unfortunately, I keep getting a message saying “We could not find an SPF record on your domain.”

So, I added this TXT record to my DNS (v=spf1 include:_spf.google.com ~all) but it’s STILL not working.

Not sure what to do to fix it?

Thank you!

1 Like

Welcome to the Cloudflare Community. :orange:

What is the domain?


Thank you! It’s craftycopy[dot]co[dot]uk

(SquareSpace domain but using Cloudflare, too)

1 Like

Are your nameservers showing as carol and kyle in your Cloudflare dashboard?

Can you share a screenshot of your TXT record in your Cloudflare dashboard?

Yes, they are! And I’ve screenshotted all my DNS records (including the TXT) as well as the nameservers on both Cloudflare and Squarespace.

(by the way: I really apprechiate your help! Just been so stuck for days)

The SPF record isn’t in your screenshot and isn’t coming up when requested. Can you enter it again?

dig +short craftycopy.co.uk txt


As @sjr has observed, the SPF record is not visible in the screenshot you shared. That would explain why we’re not seeing it returned in our queries. We can check again after you create it.


Thank you for letting me know, @epic.network @sjr ! Isn’t it the one at the bottom of the screenshot?
Either way, I tried again (unless I’m missing something obvious or doing it wrong):

No, you need to create another TXT record with the name @ and content of
v=spf1 include:_spf.google.com ~all


Ohhh that’s what I was doing wrong! I had replaced my existing TXT record with that content, originally.

Just logged into my Dubsado AND IT WORKS.

Thank you SO much, @sjr and @epic.network . You’ve been super patient and kind! I really appreciate that


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.