TXT Record not propagating

I have created a new TXT Record.
I used the @ as the name, but that defaults to a domain name
I used www as the name and that record was accepted but it is still not propagating

I have put the correct “Content” in that section

I have followed the tech advice from my email provider but they they are still not able to do anything to set up my Office 365 email, because the TXT record hasn’t propagated. This problem has been happening now for about 4 days.

The Microsoft validation TXT record should be created at the top level of your domain, which is sometimes called “@”. When creating the record in Cloudflare it will look like this:

Can you share the domain, and a screenshot of the relevant entry from your DNS panel in Cloudflare (redact any sensitive elements, like your origin IP addresses) it will be easier for the community to help.

Hi Michael
Thanks for the response.
I tried to create the record using @ but when I hit “Save” it changes the @ to my domain name musicbusinesseducation.com.au
So I tried www instead of @ and it accepted that, but it still didn’t propagate.

Hi there,

I’ve just taken a look at your DNS records for musicbusinesseducation.com.au and I can see the TXT record you added.

dig musicbusinesseducation.com.au TXT

; <<>> DiG 9.10.6 <<>> musicbusinesseducation.com.au TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4088
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;musicbusinesseducation.com.au.	IN	TXT

;; ANSWER SECTION:
musicbusinesseducation.com.au. 83 IN	TXT	"google-site-verification=Lq-Cf3fB3CCCMBj2CKtn-VqAV9roJbtmQJW39T2zjHk"
musicbusinesseducation.com.au. 83 IN	TXT	"v=spf1 include:spf.protection.outlook.com -all"

;; Query time: 53 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Fri Sep 11 12:43:18 BST 2020
;; MSG SIZE  rcvd: 198

Please can you let me know if you expected to see other DNS records.

2 Likes

I am trying to add the TXT Record but my email provider still can’t see the update? Any advice?

That is correct, @ stands for the naked domain. Leave it configured like that.

1 Like

Matteo - I’d like to leave it like that but whether I save it it defaults to the domain name!

Leave with the domain name, that’s what I was saying. @ and example.com mean the same thing in DNS.

1 Like

I think you’ve created the DNS Record correctly but would you mind providing what your email provider is expecting to see and I can see if it’s set correctly?

Right, I understand.
Unfortunately my email provider is still not seeing the update.
I’m getting this:

Sorry, we can’t verify your settings, yet. It can take up to 24 hours for us to detect the update. Please double-check you entered the information correctly, and try again in a bit.

It’s been three days :frowning:

You didn’t add it, though… it’s not there. Can you share a screenshot of the DNS page (cover any possible IPs you don’t want leaked).

  1. Sign in to your account at the other company.
  2. Find where to add a TXT record and enter

Screen Shot 2020-09-11 at 11.15.10 pm.png

That seems strange. Can you try deleting it and waiting a few minutes before re-adding it?

I’ve just taken a look and it seems you’ve added the name twice, so it’s been added to Cloudflare as musicbusinesseducation.com.au.musicbusinesseducation.com.au:

➜  ~ dig musicbusinesseducation.com.au.musicbusinesseducation.com.au TXT

; <<>> DiG 9.10.6 <<>> musicbusinesseducation.com.au.musicbusinesseducation.com.au TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32765
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;musicbusinesseducation.com.au.musicbusinesseducation.com.au. IN	TXT

;; ANSWER SECTION:
musicbusinesseducation.com.au.musicbusinesseducation.com.au. 299 IN TXT	"MS=ms50481733"

;; Query time: 131 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Sep 11 14:26:44 BST 2020
;; MSG SIZE  rcvd: 114

1 Like

I’ve done that a couple of times.
I’m confused why its not propagating

This is your answer. You haven’t added it correctly… removing and re-adding should fix things. Make sure there are no repetitions.

This is what I’m seeing when I try to Edit it.

Screen Shot 2020-09-11 at 11.40.34 pm.png

Delete the record and add it with @ in the first field (the taller one under name).

any ideas?