TXT record cannot be resolved by some validators

Previously (about 2-3 years ago) validated my TXT records for ZOHO. All worked fine, but about 2 weeks ago I wanted to change mail service to Tutanota. So I removed the ZOHO TXT and MX names and added new ones for Tutanota. The Tutanota validation TXT never worked, I see them in Cloudflare dashboard I even can see them in DNS lookup tools, but they never got validated by the tutanota service. But the funniest part is that I cannot validate ZOHO TXT values now, after I thought it’s Tutanota problem I wanted to switch back, but now I cannot be validated by ZOHO :rofl:

What can be a problem?
I set TTL to 5 min
Added the TXT record about 2 hours ago.
Triple checked the values.



Well, these are all the TXT records configured for that domain

k=rsa; t=s; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDPtW5iwpXVPiH5FzJ7Nrl8USzuY9zqqzjE0D1r04xDN6qwziDnmgcFNNfMewVKN2D1O+2J9N14hRprzByFwfQW76yojh54Xu3uSbQ3JP0A7k8o8GutRF8zbFUA8n0ZH2y0cIEjMliXY4W4LwPA7m4q0ObmvSjhd63O9d8z1XkUBwIDAQAB
v=spf1 include:spf.tutanota.de -all
v=spf1 include:zoho.com ~all

Looks all right to me.

Yes, the problem is that mail services cannot reach those records.

Well, then you need to contact them and ask why they are having issues. The records themselves are there.

Cannot believe two mail services facing the same problem.
I changed domain registrar to Cloudflare couple months ago, can it be an issue?

The registrar doesnt influence DNS. Your records resolve fine and if their values are what you were supposed to configure the issue is on their side but that is something you need to clarify with those service providers.

If that’s a DKIM record, it should be at some other subdomain, not the zone apex. <service name>._domainkeys or so.

You have two conflicting SPF records. I’m not sure that will work.

So simply an invalid configuration. In this case its not them nor Cloudflare. You need to fix your settings.

Yes, now I see. The problem is only in Tutanota service.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.