Two Domains - One Forwarding, One Not - Exact Same Settings

Hi all, hope you can help me with a brain fryer.

I have forwarding set up on two domains, with exact same settings across to board, to the letter, and one is forwarding perfectly, the other refusing to.

bendonovan.co.uk is working
impactunltd.com is not

They should both be forwarding to brandbuilderuni.com

They are all registered with GoDaddy, but using Cloudflare nameservers.

CNAME www is not proxied - I read that maybe it should be? but bendonovan.co.uk hasn’t been proxied for some time but is forwarding fine? So I didn’t want to risk changing it.

Identical catch-all page rule on them both:
[asterisk]impactunltd.com/[asterisk] redirects to https://www.brandbuilderuni.com
and also
[asterisk]bendonovan.co.uk/[asterisk] redirects to https://www.brandbuilderuni.com
(actual asterisks in actual page rules :sweat_smile:)

Any help for this massive noob much appreciated!

Page rules will only fire on proxied records.

However, as far as I can tell the origin performs the redirect already anyhow

$ curl -sI http://impactunltd.com | grep -i Location
Location: https://www.brandbuilderuni.com

$ curl -sI https://impactunltd.com | grep -i Location
location: https://www.brandbuilderuni.com

$ curl -sI http://www.impactunltd.com | grep -i Location
Location: https://www.brandbuilderuni.com

$ curl -sI https://www.impactunltd.com | grep -i Location
location: https://www.brandbuilderuni.com

So they do, maybe I just needed to be patient. Thank you for your reply, much appreciated.

As for the proxy issue - should I just leave it as it is working? Or do you suggest changing it? Thank you!

I depends on whether you want to proxy it. If you want page rules to fire, you’ll have to proxy it, however I believe your service provider already is on Cloudflare, hence the UI will probably not allow you to change that (you can’t double proxy).

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.