Two A records for a single domain

I seem to have two A records for my domain and it’s making it impossible to connect my domain to where I’m building my website. Any insight into how to resolve this issue would be greatly appreciated!

Hi there, thanks for reaching out to the Cloudflare Community!

If you have more than one A record for the same hostname, we will pick one of the addresses each time to route to, this is called Round-Robin DNS:

If you only have one server hosting your site then it’s likely you only need one of them, you should check the IPs of your origin and remove one if needed.

1 Like

Are there two IPs in the Cloudflare dashboard DNS app or are these two Cloudflare proxy IPs being returned by a DNS query? The latter is normal when a hostname is :orange: proxied. You may need to switch to :grey: DNS Only when trying to validate a name with a third-party service.

Thank you for your comment but unfortunately it’s still not verifying :expressionless:

What is your domain name and what records have you been asked to add to integrate your site with your service provider?

The domain name is and we are trying to build the website on They are asking us to go to the Domain Settings (under your Domain provider website) and make the changes below in your Records:

Type: A

Host: @


I’ve added them on the DNS records page. Am I missing a step?

I see that record. You can, too, by simply looking up your apex name (without the www). You don’t have any DNS record for www which means that name goes nowhere right now.

Do you have a link to their directions? I can’t find links to their support and documentation area from their overly cluttered homepage.

Here is a screenshot of the page where you link a custom domain. There weren’t any instructions per se.

I bought the domain on Cloudflare - is that who would generate a DNS record?

You already created the record shown in that screenshot. You can enter your domain name into and DnS lookup tool and confirm it.

Dig (DNS lookup)

You should probably ask them if their directions are missing something. They show your domain name with the www but provide no guidance on what to use for that name.

Have you tried adding a matching record for www?

I was trying to connect it without the www. So silly. It’s connected now. Thank you for your help and the tools to check the DNS!

1 Like

You were doing exactly what their directions said, so no one would fault you for that. :grin:

I’m glad to hear that you succeeded in connecting your domain.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.