Turning on cloud flare proxy

Turning on cloud flare proxy

Hi everyone,

I have some problem with Cloudflare proxy,
I imported DNS records from Goddady and everything is working correctly,
Also, I created some new subdomain with A records pointed to my proxy server, But first I couldn’t to request an SSL certificate in my server, so I turned off always HTTPS and after this, I could request SSL certificate on my server,

Now, when I turned off Cloudflare proxy my subdomain is loading with my SSL certificate, But my subdomain is not loading when I’m turning on Cloudflare proxy

What is the issue?
What should I do?

May I ask is the subdomain like sub.yourdomain.com or www.sub.yourdomain.com in terms of an possible “subdomain deep-level issue”?

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.