Turned on Gateway > Policy Settings > Whatsapp can't download image

It’s strange. My whatsapp can’t load image sent by others on my iOS.

Can you confirm the config you have here - what policies do you have set?

I didnt set much policies. Attached is my configuration.

You probably need to add a Do not Decrypt rule for WhatsApp and other cert pinning applications.

Skip inspection for groups of applications · Cloudflare for Teams documentation

I had the same, not only Whatsapp, but also my banking app and other apps (Tesla, …) didn’t work anymore. Next to what @cs-cf mentioned, you can also disable TLS Decrypt in Gateway > Policies > Settings

By the way, @cs-cf , is it possible to add manually an application instead of using the Cloudflare list of certificate pinned resources? My banking app is not in the list for example… (or is there a way to submit apps which rely on certificate pinning?)

I’ve managed to resolve this by whitelisting WhatsApp subdomains!

Gateway > Policies > created a policy to Allow Whatsapp hostnames

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.