Turn off SSL to fix broken site

I have been running my site rogerlapin.co.uk through Cloudflare for a year now without any issues.

Yesterday I tried to enable W3 Total Cache on my site which killed it and I got the Cloudflare - Site Down 521 error.

My hosting were not able to help me fix the problem and said it must be a Cloudflare issue.

I knew it wasn’t but now today still have a dead site which I need to rebuild.

My problem is that my https is being served form Cloudflare but until I can get a clean wordpress install up I can’t get this to work, so want to turn off https on my domain name temporarily

I have clicked the www cloud to grey and disabled SSL in the SSL/TLS app, but whenever I try to hit my site its redirecting to https

I am a bit stuck on how to fix my site,

My plan is to flip my nameservers back to my hosting and then bring up the site on http add the ssl plugins re-configure to https and re-point to Cloudflare, but Ideally I just want to disable https temporarily but I can’t seem to do that?

http://www.rogerlapin.co.uk continues to point to https

I would usually never suggest that, so should you ever tell anybody else that this recommendation came from me I will vehemently deny everything :smile: but I guess yours is one of those one in a million cases where Cloudflare’s Flexible mode might be temporarily appropriate.

I presume you currently have “Full strict” in place, dont you? You could switch that to “Flexible” in that way Cloudflare will still serve your site via HTTPS but will actually connect via HTTP to your server. That should fix the issue, assuming it is an HTTPS issue on your server.
Alternatively you could switch to “Off”, which will also connect via HTTP, however Cloudflare wont even serve your site via HTTPS but will redirect all HTTPS requests to HTTP. “Off” is definitely the more upfront choice, but if you only need it temporarily Flexible might be a quick workaround.

Again, this should only be a temporary measure until you fixed the server.

1 Like

thanks for the reply Sandro,

I have switched to off right now but when I connect to http://www.rogerlapin.co.uk it is still re-directing to https

Am assuming this is coming from Cloudflare bus want to disable this behaviour for a while.

That redirect might be cached in your browser. Currently it does not redirect to HTTPS, but to a Wordpress setup on HTTP.

After a website crash I have recovered my site and can how access the home page using https

However all other pages / including wp-admin are not https and I am locked out of dashboard

Going to have to revert back to http to try and fix, but why would just the home page be https?

All other pages are getting a refused to connect error

Maybe your home page is cached. What’s the domain?

Thanks -https://www.rogerlapin.co.uk/

Seems to have sorted itself now, most likely cached

All pages working correctly

However I have to run in Flexible mode - if I turn on Full it breaks so need to speak to my hosting on Monday to see what the issue is there

1 Like

Hi @roger5,

Can you expand on what currently happens if you enable Full?

I get Error 521 site down

If I enable Flexbile (current setting) it’s working fine

Do I need to get a certificate on my hosting?

Here is an extract from the error 521 community tip.

seeing a 521 over HTTPS, it is possible that your origin server has not been configured to allow port 443 be accessed by Cloudflare IPs. In this case you should configure your server/firewall to being listening on port 443 and allow us to be able to conect.

Community Tip - Fixing Error 521: Web server is down

I would suggest this is the issue here, and if you get a certificate on your server, I would expect it to work in Full (strict) mode.

Short answer:

Yes! :slightly_smiling_face:

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.