Tunnel worked for a few hours and then stopped

Doing some more testing and here’s what I’ve found:

If I disable “no TLS verify,” I get error 502: Bad Gateway
If I enable “no TLS verify,” the connection times out, but I do see in the URL of the browser that it is directing me to https://192.168.1.128:9001/login, so it is getting partway there, that’s the login page for Nextcloud, it’s just not loading.

Nextcloud is using an origin certificate generated by Cloudflare

Here is the config for the tunnel:

And the SSL/TLS setting is set to Full(strict), but I’ve tried changing to flexible and that doesn’t fix it.

Any of this look wrong?