Tunnel worked for a few hours and then stopped

I’m using a tunnel to access a Nextcloud instance from outside the network. It was working fine when the server was using http. However when I enabled https on the server, I got it working but then it stopped and I can’t tell why or get it working again.
The Nextcloud instance is still accessible on the local network, so it’s something to do with the connection between Nextcloud and Cloudflare.
The connection simply times out.
The reason I’m particularly confused is that it seemed to stop working without me changing anything.

I turned on NoTLS Verify. That made it work for the little bit that it did.

Anybody have any ideas for what I should check?

Bump.

I would check the configuration of the tunnel to make sure that it maps to the new port for the HTTPS service.

It’s mapped to the right port, unless there’s something that I don’t understand.
Also, if I navigate to my tunnel in a browser on the LAN of the server, it works. Which I don’t quite understand since I thought that even if you are on the same LAN, your request would still be routed through Cloudflare.

And I did make sure to change the public hostname service type to https for the tunnel if that’s what you mean.

Doing some more testing and here’s what I’ve found:

If I disable “no TLS verify,” I get error 502: Bad Gateway
If I enable “no TLS verify,” the connection times out, but I do see in the URL of the browser that it is directing me to https://192.168.1.128:9001/login, so it is getting partway there, that’s the login page for Nextcloud, it’s just not loading.

Nextcloud is using an origin certificate generated by Cloudflare

Here is the config for the tunnel:

And the SSL/TLS setting is set to Full(strict), but I’ve tried changing to flexible and that doesn’t fix it.

Any of this look wrong?