Tunnel not creating route (seeming CNAME)

My current goal is get my original tunnel working again. Before, I was trying to access a different computer that was on the same network as the computer hosting the cloudflared service.

When I add a Public Hostname to my tunnel, I original had it working and was able to access my computer hosting the service. When I tried to add another hostname to route to the second computer, the second would route to the first computer. My urls were as such

  1. com.someurl.xyz
  2. com.someurl.xyz/other
    When I changed the second to com2.someurl.xyz I was able to access the second computer.
    However, I wanted to keep the above where base url is the same and just changing the path would specify which computer.
    In the end, I deleted my original com.someurl.xyz to test things and now it is all broken. I can’t access my original computer. I tried reinstalling the service and updating cloudflared.

Looking at the DNS records I saw that creating the public hostname was not automatically creating my CNAME route like it did before. Right now, Routes comes up as – in the Tunnels dashboard.

I tried manually setting the DNS record with the CNAME as my desired name (com) and the content as the tunnel ID. (I tried this because this is what it looked like it was doing for other tunnels I made)

Can someone please help me get my original tunnel working again.

Forgot to mention, when I try to connect, I get this error. Probably because it doesn’t see the host
ERR failed to connect to origin error=“websocket: bad handshake” originURL=https://com.someurl.xyz

I set the content to: tunnel_id.cfargotunnel.com and it worked. :grin:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.