TTL txt record set to 1hr yet when I look up it's 5min (auto)

I need it to be 3600 for domain verification on Azure

Azure requires specific TTL 3600

Can you post the record in question?

Good point. It doesnt seem to matter what one chooses, it is always set to 300 seconds. Either the entire TTL selection is obsolete or there is some glitch.

Case for a support ticket I’d say :slight_smile:

2 Likes

I believe this is specific to the TTL for TXT records on the root only and an artifact of our setting CA records for SSL issuance. It’s a known issue IIRC and shouldn’t impact the validation for Microsoft in this instance.

2 Likes

I successfully verified my domain even with the wrong TTL on the TXT record.

The reason Azure was not verifying the TXT record was due to a typo, my bad.

However, I suggest to Cloudflare to remove TTL option on subdomains since they aren’t applied anyway. It creates confusion.