Ttfb time increase after using cloudflare

I am using digitalocean data center is in India. When I don’t use cloudflare proxy it gives me around 200-250 ms TTFB - time to first byte. But when I use cloudflare proxy TTFB becomes 550-670ms site become slow. I am using Argo smart routing also. But no improvement. What should i do?

Check your site at https://cloudflare-test.judge.sh and post a full page screenshot of it.

Here is my report. and my website https://ringtonehd.com

Assuming your site is on the free plan it appears your ISP routes you via the British datacentre, that would explain the increase in latency.

I use this tool https://tools.keycdn.com/performance?url=https://ringtonehd.com/ to check ttfb time. Without Cloudflare, it gives me 200-250ms TTFB but with Cloudflare, it increases to 500-670ms sometimes even 800-900ms. Now it’s giving me 800ms ttfb time.

TTFB in this case seems to be a latency issue and that is because of the PoP.

In my case the site loads in about a second, however the site has issues with concurrent requests -> sitemeer.com/#https://ringtonehd.com/ but that is something that needs to be fixed on the server.

What should i do in my server can you please suggest ?? i have root access, and using cpanel. any setting??

Server administration is covered at StackExchange.

I have upgraded to pro. But still no improvement. I Contacted server admin he said no issue in server. Contact with cloudflare.

From your screenshot it appears only an Enterprise plan gives you more or less a guaranteed Indian connection. That is slightly odd and also depends on your ISP, but maybe Cloudflare can also shed some light, especially now that you are on a paid plan.

This topic was automatically closed after 30 days. New replies are no longer allowed.