Trying to setup Cloudflare DNS to point Siteground domain to Adobe Portfolio servers

Hi there,

Trying to cut a long story short: I’m new to DNS management and Cloudflare. I’ve been hosting my wordpress self-hosted website on Siteground from a while. The domain is registered through them as well. I’ve now decided to start using Adobe portfolio so I’m trying to point my ‘Siteground’ domain to Adobe Portfolio servers.

I followed all the initial 4 steps described in Cloudflare tutorial to get started that means I imported the DNS from Siteground automatically. So far so good, I could load my Siteground-hosted website after propagation. So I followed the adobe tutorial to point the domain to Adobe.

I’ve changed the following DNS to point to their servers (XXX.XXX.XXX.XXX is the IP provided by Adobe).

A * XXX.XXX.XXX.XXX

A davidbenedetti.it XXX.XXX.XXX.XXX (Orange Cloud)

CNAME www 'is an alias of davidbenedetti.it’ (Orange Cloud)

While I didn’t touched any other records (as I still want my email to go through Siteground): some MX, TXTs, ftp, localhost and mail.

Once the changes have been applied I tried to load the website but something is wrong. When I visited the website url I got redirected to https://portfolio.adobe.com/missing so I tried to complete the connection through the Adobe panel but still nothing (after pointing the DNS to their server you have to insert your domain in an control panel). I reached their support and they says: Cloudflare, being a traffic management/security company, does redirect traffic through their servers which creates a mask for the ultimate destination IP. By going to Cloudflare and clicking the orange cloud, traffic is then not directed through Cloudflare’s security servers. You’ll need to reach out to Cloudflare so that they can help you through this process!

Basically my question is what am I doing wrong? About the Orange cloud that their support mentioned, I’m just following Cloudflare instructions. As Adobe suggest I also checked the DNS at https://www.whatsmydns.net/ but I get an error as well.

1 Like

Try setting both entries to :grey: and see if that helps.

Trying again now as I’ve already tried but not sure how long is going to take for the change to go into effect? Thanks

DNS changes here set to Automatic take 5 minutes.

Still redirecting to the same https://portfolio.adobe.com/missing

If it’s :grey: and not working, you’ll have to contact Adobe’s support for help. You’ve done exactly as they’ve instructed. It just sounds like their server isn’t configured for your hostname.

Actually I think it worked sorry, forgot that I should connect from the adobe side as well. But I get a ‘Warning: Potential Security Risk Ahead’ page in firefox. Will dig into it and see if I will find a solution.

It could be that Cloudflare was set to HTTPS using SSL: Full (Strict) setting, but because Portfolio doesn’t have a valid certificate for your domain, it malfunctioned.

It would be nice if they could provide a valid SSL Certificate for your domain. Otherwise you may have to resort to the Full (not strict) setting.

An update for posterity: Adobe at the moment support SSL for custom domain, it takes up to an hour for the Certificate to be emitted. So I set Cloudflare SSL too Full (strict) and it’s all set now. Thanks a lot for your help. :bowing_man:

2 Likes

This topic was automatically closed after 31 days. New replies are no longer allowed.