Trying to create a subdomain but it keeps pointing to the root

I am using runcloud and want to create a subdomain to host myphpadmin application.

  • I created the Web App and said that the address would be a [sub] . [domain] . com
  • It instructed to do an A record sub IPV4

I came to cloudflare and created this record under my domain .com
The address [sub]. [domain] .com is pointing to [domain] .com and not to myphpadmin web app.

I’ve done this before and it worked? I am not sure what I am missing - I thought it might need more time to propagate but I also had tried to make a few other subdomains in the past and they too all point to the root?

Thanks

What is the domain and subdomain?

1 Like

digitally . so

msql . digitally . so

They go to different places for me.

digitally.so goes to a “Coming Soon” parking page.
msql.digitally.so goes to a phpMyAdmin login page.

This seems to be what you wanted.

curl -I https://digitally.so
HTTP/2 200
date: Sat, 17 Feb 2024 12:19:02 GMT
content-type: text/html; charset=UTF-8
vary: Accept-Encoding
link: <https://digitally.so/wp-json/>; rel="https://api.w.org/", <https://digitally.so/wp-json/wp/v2/pages/524>; rel="alternate"; type="application/json", <https://digitally.so/>; rel=shortlink
x-frame-options: SAMEORIGIN
x-xss-protection: 1; mode=block
x-content-type-options: nosniff
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=IatGHTsFVSw%2BugOlZnjrGg69H0Ocfw7n3xggcevmLmljVkMDcxa7ZOio5C84hZxmFobV1vUj9xCbQ8Ggp9t2whShdnOQPfk7yzrLE6p6r3ToYXFRPdnRgfMvn%2BYJBFRh%2BE%2FAuYWOsaE9mVY%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 856df9eebc22dc9b-LHR
alt-svc: h3=":443"; ma=86400
curl -I https://msql.digitally.so
HTTP/2 200
date: Sat, 17 Feb 2024 12:19:13 GMT
content-type: text/html; charset=utf-8
set-cookie: pma_lang_https=en; expires=Mon, 18-Mar-2024 12:19:13 GMT; Max-Age=2592000; path=/; secure; HttpOnly; SameSite=Strict
set-cookie: phpMyAdmin_https=5vdkgaf9knfdi5mmub9rp243ov; path=/; secure; HttpOnly; SameSite=Strict
x-ob_mode: 1
x-frame-options: DENY
x-frame-options: SAMEORIGIN
referrer-policy: no-referrer
content-security-policy: default-src 'self' ;script-src 'self' 'unsafe-inline' 'unsafe-eval' ;style-src 'self' 'unsafe-inline' ;img-src 'self' data:  *.tile.openstreetmap.org;object-src 'none';
x-content-security-policy: default-src 'self' ;options inline-script eval-script;referrer no-referrer;img-src 'self' data:  *.tile.openstreetmap.org;object-src 'none';
x-webkit-csp: default-src 'self' ;script-src 'self'  'unsafe-inline' 'unsafe-eval';referrer no-referrer;style-src 'self' 'unsafe-inline' ;img-src 'self' data:  *.tile.openstreetmap.org;object-src 'none';
x-xss-protection: 1; mode=block
x-xss-protection: 1; mode=block
x-content-type-options: nosniff
x-content-type-options: nosniff
x-permitted-cross-domain-policies: none
x-robots-tag: noindex, nofollow
expires: Sat, 17 Feb 2024 12:19:13 +0000
cache-control: no-store, no-cache, must-revalidate, pre-check=0, post-check=0, max-age=0
pragma: no-cache
last-modified: Sat, 17 Feb 2024 12:19:13 +0000
vary: Accept-Encoding
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=g8dd0BbMA2XPse0CGOQJKElFrlx8jw7qSEvaVr%2FWe56%2Bs%2BwL%2FGnCwRmXp5qvbSzNfITbrL3gGogjH639af5Z8BlDhPwaitYQ6MpovZXkYn%2FvPKtnpe%2B11papp%2BLPoXtdixOg%2FVmPraouQpC0Lv4AHA%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 856dfa35ea32386e-LHR
alt-svc: h3=":443"; ma=86400
1 Like

Yes thank you - I had a call for help on another site too - and it was missing the SSL certificate. I just came back to update you - I will keep this up for others who might experience the same thing. It is also important for others in the future to clear your cache after adding the SSL.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.