Trying to configure Verizon FiOS MI424WR-GEN3I

Results of Cloudflare’s diagnostic tool: https://Cloudflare-dns.com/help/#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6IlllcyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjExMTEiOiJObyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjEwMDEiOiJObyIsImRhdGFjZW50ZXJMb2NhdGlvbiI6IklBRCIsImlzcE5hbWUiOiJWZXJpem9uIEludGVybmV0IFNlcnZpY2VzIiwiaXNwQXNuIjoiNzAxIn0=

I’ve followed the instructions here: https://forums.verizon.com/t5/Fios-Internet/Can-I-enter-Google-DNS-in-MI424WR-Gen-2-router-modem/m-p/538189#M35561

I’ve forced both the Broadband Connection (Ethernet/Coax) and the Network (Home/Office) DNS servers to 1.1.1.1 and 1.0.0.1.

However, I cannot get Google Chrome 70.0.3538.77 (Official Build) (64-bit) on Ubuntu 18.04.1 LTS to resolve to 1.1.1.1, as evidenced by the diagnostic tool information, as well as the standard test on https://www.dnsleaktest.com/.

Any ideas?

Cam you run nslookup example.com or dig example.com from your computer’s terminal/command prompt? That should show what DNS server it’s using for lookups.

[email protected]:~$ nslookup example.com
Server:		127.0.0.1
Address:	127.0.0.1#53

Non-authoritative answer:
Name:	example.com
Address: 93.184.216.34
Name:	example.com
Address: 2606:2800:220:1:248:1893:25c8:1946

[email protected]:~$ dig example.com

; <<>> DiG 9.11.3-1ubuntu1.2-Ubuntu <<>> example.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18363
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;example.com.			IN	A

;; ANSWER SECTION:
example.com.		86387	IN	A	93.184.216.34

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Nov 19 17:52:47 EST 2018
;; MSG SIZE  rcvd: 56

Are you running a local DNS over HTTPS client, DNS over TLS client, or perhaps some Verizon software on your machine? The server being 127.0.0.1 is odd, as that setup looks like it would just broadcast the 1.1.1.1 resolver to all connected devices.

Only thing I can think of is the HTTPS Everywhere extension for Chrome. Might that affect configuration outside the browser?

Or perhaps XAMPP?

Disabled HTTPS Everywhere in Chrome, uninstalled XAMPP, and rebooted, to no avail. Still showing 127.0.0.1 and still not resolving to 1.1.1.1 in the diagnostic tool.

Can you try manually setting the dns to CF addresses in your network settings?

Yeah, that’s what’s especially puzzling. 127.0.0.1 persists even if I do manually set to 1.1.1.1 and 1.0.0.1 on the Ubuntu machine.

Something is definitely wrong somewhere in the guts of Ubuntu, because I can resolve to the Cloudflare addresses just fine on an iPhone on the same WiFi network, even without the iOS app “enabled.”

Figured it out!

My results: https://Cloudflare-dns.com/help/#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiTm8iLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiTm8iLCJkYXRhY2VudGVyTG9jYXRpb24iOiJJQUQiLCJpc3BOYW1lIjoiQ2xvdWRmbGFyZSIsImlzcEFzbiI6IjEzMzM1In0=

Turns out that Ubuntu changed some defaults to be fairly non-standard: https://www.reddit.com/r/Ubuntu/comments/8kp6fn/dns_issues_with_1710_and_1804/

Following those instructions to switch back to dnsmasq got 1.1.1.1 working for me.

1 Like