Trying to add my site and it says it is invalid

Trying to add my new site and it says it is invalid. http://list-okc.com/

Probably because your site is not secure yet. You need to fix that before you add it to Cloudflare and make sure it loads fine on HTTPS.

1 Like

I’m adding the site to Cloudflare to add the SSL I have no other way to secure it. I added all my other sites before I secured them.

I am afraid that’s not how it works. Cloudflare can’t provide SSL if your site is not secure on its own. You first need a proper setup on your server.

If you have other sites without SSL, then all your sites are insecure and you should fix them too.

are you talking about an ssl

That’s what I have been saying, right? Cloudflare can’t secure an insecure site, your site needs to be working fine on HTTPS first.

Nope. I added all my other sites before I secured them here on Cloudflare with an ssl

Then you still have insecure sites and need to fix this as I mentioned.

You are being to
vague

All right, you need to talk to your host and get your server properly configured for SSL.

What are you talking about. I have 6 other sites that had no ssl before I joined Cloudflare for the ssl’s

We are going in circles, I already wrote everything that needs to be done.

Bottom line, all your sites are insecure right now.

You are going in circles acting like your helping me and I told you I got every one of my ssl from Cloudflare with all unsecured sites. Coudfares says my domain is invalid. thats an error on Cloudflare my domain is valid

I told you that all your sites are insecure and you should fix that. Not sure what’s so difficult to understand about that. By now you could have already fixed that instead of repeating the same question over and over.

Here is another one of my sites and it had no ssl before I got it here.https://abba-service.com/

If you don’t have a certificate on the server - as you mentioned - it is technically not possible to be secure. You will also have an insecure encryption mode on Cloudflare.

1 Like

Wow. I’m just beating myself in the head I guess. Every one of my were non secure sites after I built them until I came here and got an ssl for each one. My server is already working with all of them.

Precisely, that’s what I have been saying. Your sites are currently insecure and you should fix that if you want a secure site. It’s a matter of minutes.

Its sad I’m driving you crazy

ok so
you went to https://abba-service.com/ and its not secure?