Trying to add DS record but facing error code 104

Hello, iam trying to add DS record but facing error code 104, and my domain registrar can’t add the record because the server names are with cloudflare, what is the solution?

DS records for the domain need to be added at the registrar, not in the DNS records for your domain (whether that be at Cloudflare or anywhere else).

What is the domain?

how i can add the DS record?

At the registrar.

What is the domain? (or who is the registrar?)

Bluehost

Adding Delegation Signer (DS) Records | KnowledgeBase (China link, but I guess the same elsewhere). You need to use the DNSSEC section, not adding DS records to the DNS.

Use the DNSSEC info from…
https://dash.cloudflare.com/?to=/:account/:zone/dns/settings

1 Like

i am confused, bluehost saying i must point server name to them again so they can add te record

If you put the nameservers back to Bluehost, then you can’t use Cloudflare.

Try this post (change the hostname at the end of the link to yours)…

1 Like

Please contcat them and inform its not possible to add from registrar end nameserver should point to us to add DS records
this is bluehost support response

Did you try the link in the post linked to above?

Your options:

  1. Keep nagging Bluehost, you can see from the link above it takes work. Have you actually passed them the records to set from your Cloudflare dashboard?
  2. Change your DNS servers to Bluehost as they ask, but you cannot then use Cloudflare for your site.
  3. Move your domain to a registrar that supports DNSSEC better.

What is the domain name?

1 Like

Yes i have passed the record to them, and keep saying i must point name server to them so they can make changes, after i change again to cloudflare

Your best option when dealing with that provider tends to be:

That won’t work. If Bluehost add DNSSEC signatures for the domain while it is pointing to their nameservers, and then you change the nameservers, the DNS signing will become invalid and your domain won’t resolve for resolvers that use DNSSEC. (That’s the point of DNSSEC after all!)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.