Troubleshooting Brotli - No Workie

Greetings everyone,

Brotli compression has generally always been enabled (via the CF Dashboard) on https://goseongguy.com/. It was working in the past, but has stopped working at some point since.

In case it matters, I am caching content using the Cloudflare Super Page Cache plugin on WordPress. I’m using the plugin’s worker mode (as opposed to the plugin’s page rules mode for caching).

If I understand correctly, if my server is outputting GZIP content then Cloudflare will skip using Brotli. I am not aware of any explicit setting on my server shipping GZIP. My .htaccess and php.ini has php_flag zlib.output_compression Off.

Anyway I observe the following response header: content-encoding: gzip
Expected behavior: content-encoding: br

The only other idea I have is regarding the word “immutable” in the cache-control header as a result of the Cloudflare SPC plugin, but I’m not sure this is anything to be concerned with.

Is anyone able to advise further troubleshooting to get Brotli compression working?

Thanks,
Nate

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.