Troubles with Origin Certificate


#1

Hi guys,

Previously I ran Let’s Encrypt just fine before and ran into problems when I had to renew. So i started to look into Origin Certificates.

But i seem to be getting an issue when I apply the Full(Strict) mode. I had successfully installed the certificate on my hosting server (At least I think I have.)

If i attempt to refresh the page without CloudFlare active i get a NET::ERR_CERT_AUTHORITY_INVALID message.

If I turn on cloud flare Full Strict or Full it suggests that my Host is down or Invalid (502 error)

If i turn on flexible mode it works fine.

Any suggestion to what I could be doing wrong?


#2

Any ideas?


#3

Just stumbled across your post and followed the instructions in your CABUNDLE which on my provider’s CPANEL has a separate area to paste that 3rd key. However like you if I have full enabled I get the same type of error page.

I have HTTPS Everywhere extension I enabled in Chrome yet a normal connection without specifying https: in the URL results in a non secure connection.


#4

Hey,

Just to let you know this issue has been resolved. After a few hours of troubleshooting the Cloud Flare team realised that a setting on my providers side was not configured correctly. Mind you they have over 10,000 people hosting with them and I was the first one to notice.

I am now able to now achieve full SSL mode. I would suggest contacting Cloudflare support and get them to test it for you.


#5

Just to recap, my provider had a Railgun service active and this was where the problem was found. They changed something to allow full SSL to work.

Hope this helps.


#6

I also got my issue resolved with a Wordpress site. I enabled the http to https redirect here on Cloudlfare as well as installing Really Simple SSL plugin which automatically changes any existing http:// URLs in the site to https and that got rid of the insecure warnings about loading non secure content on the stie.

Thanks again for the link for the CABundle CERT that was the first step to get this cert working with the provider.