Trouble with SRV record


We are trying to add a SRV record for our exchnage server with OVH, but everytime i add the SRV record it adds my domain behnd it.

OVH tells me to add:

SRV record

Sub-domain: _autodiscover._tcp
Priority: 0
Weight: 0
Port: 443

I do that but end up with: Whatever i try it doesn’t work, the part should not be added. I tried to contact CF avout it but the support is overcrowded offcourse. So i hope one of you can help me.

see screenshot:

thanks in advance

1 Like

Are you typing in the trailing “.” before saving the record?

Yes i am typing the trailing Dot (.) at the end.

I’m having the exact same issue today. Tried with trailing dot and without.

I originally imported the record from a zone file, thought maybe the import had an issue, so I deleted and tried again and it’s still appending the domain name to the target

( in red is just to mark out the real domain. The name and target value does not have any spaces in it. )

Am I overlooking something?

I am also seeing this issue. Even for domains I already have set - it is showing in the GUI but as long as I don’t click Save it will keep the original setting.
Have tested in both web GUI and trying to upload a correct zone file.

1 Like

I am also experiencing this issue. I have attempted to upload a manually edit file with the appended domain removed, import automatically re-adds the domain to the target. Tried adding the target with and without trailing dot, seems to make no difference.

Same here - how can this be solved?

Just ran into this myself. Changing a record with the API has the same result.

we have the same problem it just adds .domain.ext to the end for a unkown reason.
dashboard and api give the same result
also export and change the values and import it again does the same

hopefully it get cloudflare`s attention soon

I have this problem too.

just got this response from Cloudflare support… Lets hope!

z##n (Cloudflare)

Jan 21, 8:55 AM PST

Hi there,

Thank you for contacting Cloudflare Support. We’re sorry to hear that you are experiencing some difficulties with adding SRV records.

Upon reviewing this issue, we have opened an internal ticket with our Engineering team. The team will run some diagnostics, and we will keep you updated and do our best to provide you with an action plan to remedy the issue.

Kind Regards,

— edited—

I keep you guys posted, when i get another response

1 Like

I had the same response to my ticket

from the same guy

looks like the ball is rolling

Great thanks! Got same response as well, crossing my fingers for quick fix for everyone…

Just wanted to add that we’re having the same issues with our SRV records. Microsoft Teams/Skype for Business services are down as a result.

We are also having this problem.

This just came in:

D****n Parker (Cloudflare)

Jan 22, 3:53 AM PST

Hi there,

Thank you for your patience. We believe this problem has now been solved by the engineering team. If you can let us know if you are still seeing an issue adding your SRV records.

Apologies for the inconvenience this caused.

The original problem is fixed but now I’m seeing another problem with SRV records. For records with a target of “.” (indicating the service is unavailable), the target is getting rewritten to “false”. Anyone else seeing this?

Edit: Just got a reply to my support request, they’re looking into the new issue.