Trouble with Origin Rules

Using the free tier.

I have a site on port 8443 that works fine on Cloudflare proxy (orange cloud)
https://secure.example.com:8443

Origin has the Cloudflare cert installed.

I’d like the site to be accessed without specifying port, as in, https://secure.example.com.

So set up Rules - Origin Rules:

But browser spins for a while and eventually fails, green - green - red.
A timeout occurred. Error code 524

Can still access https://secure.example.com:8443 fine.

Any ideas what I’m doing wrong?

Do you maybe have any other rules? Using custom ports is a bit funny in that some rules apply while some don’t.

Can you use https://dash.cloudflare.com/?to=/:account/trace to see if any rules apply to your request (without port) that might cause your problems?

Great idea, but alas.

I disabled all WAF rules just to eliminate any potential snags.

Then ran the trace. it showed a bunch of gray fields and eventually after some time, this:

Was never able to resolve this.

I ended up lowering the unprivileged port to 443 on my Ubuntu server so my non-root user’s program can bind to and listen on port 443. Then specified Full SSL/TLS mode in Cloudflare.

sysctl net.ipv4.ip_unprivileged_port_start=443

Now can reach the site with https and no extraneous port number needed in the URL.

Far from an ideal solution but have to live with it for now.

I have no idea why the problem occurs, but you could alternatively use a Cloudflare tunnel to connect to your system. That’s what I use for custom ports.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.