Trouble with DNS

Just gone through the steps to use Cludflare name servers. Made the changes to the dashboard at the host (GoDaddy) to add doug.ns.Cloudflare.com and jocelyn.ns.Cloudflare.com

Did that OK , then advised in the steps to change at the resgistrar (?) Used WHOIS but just get this when I enter domain name.
The requested top-level domain is not supported; this tool supports all delegated gTLDs contracted with ICANN and their corresponding second level domains.

What now? Can’t seem to revert back to default on GoDaddy site. Have I broken it?

thewalkerwife.co.uk

.uk is not supported yet AFAIK (for their registrar part), so you’d need to stay with your current registrar, however you can change the nameservers to Cloudflare to use their network services.

So everything should still work OK? I was advised to use Cloudflare as the site keeps being flaffed up as insecure and for some reason facebook won’t allow the URL in any post :frowning:

Well, the domain does not seem to exist to begin with

This domain name has not been registered.

This is what shows on GoDaddy dashboard

Nameservers

Last updated 01/01/0001 00:00

Using custom nameservers

Nameserver
doug.ns.Cloudflare.com
jocelyn.ns.Cloudflare.com

I only changed it 15 minutes ago. maybe a time thing?

Have you posted the right domain name?

I’m confused. This is my friends site. She pays GoDaddy for hosting and the domain name. The site clearly accessible at thewalkerswife.co.uk Sorry, me bad. spelling error :frowning:

Sorry Sandro, yes.

That domain exists, is currently with Godaddy but using Cloudflare nameservers.

Thanks. So the site will eventually comeback as being secure now?

You have a mixed content issue. That is unrelated to Cloudflare or registrar or your host, but an issue of how your site loads resources. Search for “mixed content” either here or on a search engine and you should find plenty of answers on how to fix that.

Thanks Sandro. So I don’t need to use Cloudflare after all? I was advised that the site needs a certificate so it doesn’t show as insecure.

You do have a certificate, otherwise your site wouldnt load on HTTPS at all. Cloudflare and its HTTPS settings (particularly the rewriting part) could fix that but its still better to address right on your site.

You probably dont need Cloudflare though only to fix “mixed content”.

GoDaddy not being helpful I’m afraid. Is it ‘mixed content’ becaiuse access to Wordpress admin is https but that the ‘public’ content is http/ Do we just ask GoDaddy to deliver all as https?

That might be Wordpress specific, you simply need to make sure that no HTTP resources are included. That could be a server or Wordpress setting.

Installed the plugin SSL Insecure Content Fixer but doesn’t seem to have fixed it. I’ll persist now that I think I know what I’m looking for. Thanks

How did you see the mixed content flags? I’m looking through web inspector in Firefox but can’t see any alerts. Would liks to external http websites come up as mixed data?

image