Trouble setting up email DNS

Hi al,
Ive been advised by my hosting provider to set DNS records for my email

I have it set to:
A mail.mysite.com my server ip
However when I try to save I get a 1004 error saying CNAME already exists with that host.

What do I do?

Do you already have a CNAME record for mail.mysite.com perhaps?

If you need any more troubleshooting please let us know the official domain name so we can look into it in more detail.

There is not a cname for that.
my domain is jamesbillingsfurniture.com

mail.jamesbillingsfurniture.com does seem to be an existing DNS entry pointing to Cloudflare.

Pinging mail.jamesbillingsfurniture.com [104.24.112.201] with 32 bytes of data:
Reply from 104.24.112.201: bytes=32 time=6ms TTL=60
Reply from 104.24.112.201: bytes=32 time=6ms TTL=60
Reply from 104.24.112.201: bytes=32 time=6ms TTL=60
Reply from 104.24.112.201: bytes=32 time=6ms TTL=60

Ping statistics for 104.24.112.201:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 6ms, Maximum = 6ms, Average = 6ms

Could you share a screenshot of your DNS entries (omit the IPs if you prefer that) as that would make it easier to possibly find a solution.

Any ideas on this?

@user6222
You do have a CNAME record to mail in there. Try removing that and you should be able to create an A record with mail. A records and CNAME records are mutualy exclusive, they can not have the same “Name” property.

1 Like

Thanks, done that but now I’m getting connection to my server timed out in my mail program Thunderbird

Did you turn off the orange cloud? That might be the issue for Thunderbird. Be sure that it is grayed out or that you have another record to the same IP address which is not proxied with the orange cloud.

When I try to turn off the orange cloud I get this message

Make sure all A, AAAA, and CNAME records pointing to proxied records are also proxied to avoid exposing your origin IP.

Did you try to “Don’t Proxy” this A or CNAME ?
I have got an external mail server but never tried to proxy them (I think this is not a good idea).

Of course your MX pointer has to be the original.
You should have an external MX pointer in your DMZ forwarding to a private mail server, how does your infrastructure looks like ?
HTTP ports supported by Cloudflare:

80
8080
8880
2052
2082
2086
2095

HTTPS ports supported by Cloudflare:

443
2053
2083
2087
2096
8443

The only option I have is proxied or DNS only. Orange cloud on or off.

how do I check this?

I would setup it off.
What kind of virtual appliance is mapping your infra at Orange do you have multiples servers there ?
It’s pretty sure to send an email, you’ll have to send it without proxied connection (grey cloud, DNS only, real IP). That’s why usuallu two MX servers are used, the first to filter spams & forward others, the second inside the company to serve users.

Thanks.
Unfortunately I dont understand much of that :confused:
I have a single hosting package with Hosting Ireland and have Cloudflare set up for CDN.
Should I change anything now?
I can receive mail to Thunderbird but I have this warning in Cloudflare:
Make sure all A, AAAA, and CNAME records pointing to proxied records are also proxied to avoid exposing your origin IP.

That is because you are not proxying (the orange cloud) your IP behind Cloudflare. That is why I suggested this:

I have a few gibberish A records pointing to the same IP address of my servers with a grey cloud and then using CNAME records pointed to those A records as subdomains that do have the orange cloud.

This way the default records like mail/www/ftp are all proxied but the gibberish ones are not and are a direct connection to the IP. That way if you really need to use the direct IP, like in Thunderbird, you can use the gibberish domain.
If you host an email service for more people this isn’t recommended but if only used by yourself it adds a bit more “security”.

The warring Make sure all A, AAAA, and CNAME records pointing to proxied records are also proxied to avoid exposing your origin IP. is only there because you have a grey cloud. In this case you are aware of that fact and know why you use it. No need to pay it a lot of attention unless you are afraid of someone DDoSing your direct IP.

Ok, so i would have something like this?

A - madeup name - my ip - auto - grey cloud
CNAME - mail - madeup name - auto - orange cloud

Or am I completely not getting it?
In which case I can just stick to what I have (grey cloud)

Exactly what I meant.
And in Thunderbird you can use the made up name as the domain name instead of mail. .

1 Like

So in cname it would have to be madeup name .mydomain.com?