Trouble pointing domain to Kajabi

I am brand new at this and just changed my nameservers to the Cloudflare ones so that my domain would point to Kajabi. (i went through the Kajabi custom domain guide.) However, the domain is still directing to a Squarespace landing page. It seems that the problem might be the A name but I’m not sure.

I went through all the steps in the Kajabi instructions without a problem. But it is still pointing to Squarespace. My domain is

Can someone please help?


www is pointing to a Kajabi site, but the naked domain is still pointing to Squarespace. Are the www and DNS entries configured the same way in your Cloudflare Dashboard DNS settings page?

Here are my settings, I would greatly appreciate it if you could let me know what I did wrong. Thank you!

Get rid of all those “A” records for

Add a CNAME record for that’s an alias for and make sure it’s set to :orange:

I suspect Kajabi isn’t going to like the naked domain, so in Cloudflare, use Page Rules (from your Dashboard) to add a rule:
Add setting: Forwarding URL that uses a 301, and set the forward to

That should do it.

When I create a page rule it says* is an invalid host. Ahhhk!

Now when I type [] does this:

And this for the CNAME record;

Maybe Page Rules doesn’t like something about that DNS entry.

Try deleting the DNS record and create an “A” record with an IP address of (just as a placeholder) that’s set to :orange:. Once the Page Rule is up and running, that IP address won’t matter.

@sdayman is there someone I can pay to set this up and get it working for me? I feel a little out of my depth.

1 Like

Time to stretch a bit…you can do this.

  1. Click on the X to get rid of that CNAME for in DNS
  2. Also on the DNS page, next to the “Add Record” button…keep the “A”, and enter for “Name” and for “IPv4 address”. Keep Auto TTL and :orange:, then click the blue Add Record button.
  3. Head over to Page Rules, and do this:

OMG! It worked!! Thank you, thank you, thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.