Trouble making my Wordpress Site TLS compatible

So I’ve been trying to get an online shop up and running with WordPress and as most of you might know, online sites require SSL security and TLS to be at or above TLS 1.2. So I came to Cloudflare to secure my website, which turned out great, I have a padlock on my site now (not the green one). But when I go back to WordPress to check TLS compatibility with a plug-in it tells me I’m not 1.2 compatible. With the main error being that my cURL is out of date. I tried coming back here to the Crypto section in the dashboard and change the minimum compatibility to 1.2 but that still hasn’t helped. I even tried manually updating my cURL on my computer.

I have free hosting with Cloudflare.

Could someone please help me fix this? I’ve been trying for two days now and still haven’t had any luck.
Thanks in advance.

What’s the domain?

It looks like you have it properly set up. It’s only allowing TLS 1.2 and above, plus it’s a valid certificate:

p.s. As for the ‘curl’ issue, that’s what’s on the server. You would have to contact your host to get that updated. But as far as TLS, your site is good.

1 Like

The green padlock has been retired by Chrome. You can still see it though if you visit your site with Firefox. :wink:

1 Like

Thank you very much for checking that out for me. I contacted my hosting provider and they are getting everything set up for me.

Thanks again!

Thank you, didn’t know that. :blush:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.