Trouble connecting to RDP server through Cloudflared tunnel

Hello,

I’m trying to use a Cloudflared tunnel to connect a remote office to our main office that doesn’t have a static IP.

I have setup the tunnel and had it connecting reliably until I started to put in access restrictions. I have since removed all access restrictions, but I continue to get the error: ERR: failed to connect to origin error- “websocket: bad handshake” when I try to connect to the public resource. In other words, it seems to connect the tunnel until I try to connect to the RDP, then it drops with the error.

This only seems to happen from my client’s remote location. When I try from my own computer, I can connect successfully.

I have ensured that websockets is enabled for this client under my Cloudflare account.

Any help is appreciated.

Trevor

Same issue with my RDP server.
Without any firewall, direct agent service running on the server and nothing happens…
Did you already have this issue solved and now working?