Trouble Connecting Domain to Kajabi

Hi!

I want to direct my domain to Kajabi. I’ve changed my nameservers to the Cloudflare ones, I’ve followed all the steps in the Kajabi guide, yet on the last step I get an error.

I already found a few similar threads (for example this: Trouble pointing domain to Kajabi) and tried out everything in there, but still getting this notification on Kajabi:
" Your custom domain has not passed some verification steps.
It looks like your CNAME record has not been set to point to Kajabi yet.
See Step 2 for more information."

Here is how everything looks on Cloudfare at the moment:

It might be that some of those settings should be removed, but I am super new to this so I didn’t want to just randomly start deleting everything! :slight_smile:

Could somebody please give me some tips?

Thank you!

Try setting that CNAME to :grey:

EDIT: And that’s the opposite of what I said in that other thread. Hold on…

Thanks! I did it, here’s how it looks now:

Though now Kajabi gives me another error:
" Your custom domain has not passed some verification steps.
We had trouble checking SSL for your custom domain. It’s possible you haven’t configured Full SSL on CloudFlare yet.
See Step 3 for more information."

And when I go to Cloudfare SSL section, it says it’s set up and has an active certificate.

Their instructions say it should be set to :orange:. And that makes sense if you’re going to use SSL set to Full.

I see right now your site says it’s powered by Podia. Is that Kajabi?

Is your “Custom Domain” at kajabi set to www? Or does it have just the domain name without www?

Hm, no, shouldn’t be Podia - that’s a totally different platform!

And on Kajabi it is set to www.im-momentsein.com
(if I try just setting it to im-momentsein.com it tells me it doens’t support apex domains)

Ok, so that’s correct. Though I don’t know why your site still shows Podia. Maybe that’s why Kajabi isn’t accepting it.

How about going to the Caching tab here and Purge Everything? (and make sure www is set back to :orange:)

Ok, purged it.

Funnily enough, Kajabi reports this error now:
" Your custom domain has not passed some verification steps.
It looks like your CNAME record has not been set to point to Kajabi yet.
See Step 2 for more information."

And where do you see that it is showing Podia?

Oh, it seems that during our trial on Podia they somehow got connected to it.
Now I wrote to their customer service, they removed it on their end and now Kajabi got connected.

Thank you very much!

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.