Trouble activating Cloudflare -- told to deactivate "thereikipage.com"

I’m trying to get setup with Ezoic and it looks like Cloudflare will be a good choice.

In any case, I have a few sites hosted with Dreamhost. Dreamhost offers a simple integration with Cloudflare where you select Cloudflare integration in the hosting settings for the website.

I’ve been able to use this successfully with two sites, but on the third ("thereikipage.com") it fails and Dreamhost tells me – CloudFlare is already activated for “thereikipage.com” under a different account. If you want to enable CloudFlare through this partner, please log in to your CloudFlare account and choose “Disconnect” on your CloudFlare DNS Settings page.

Yes, I understand what that means, and I’ve seen another post here describing what to do. I’ve logged into my account, and “thereikipage.com” is not listed. IMPORTANT I have not previously tried to use Cloudflare with this or any other domain.

I’ve sent a support ticket, and was told that there is another account besides my current account which has control over that domain name. I THINK THAT IS INCORRECT because, as I said, I have not attempted to use Cloudflare with this or any other domain in the past. In any case, I tried logging in with a couple email addresses I own by saying I didn’t remember the password. With that method I was able to login to my current account, and to another, neither of which has “thereikipage.com” listed.

The sequence of events was:

  1. I started by going to Cloudflare website and creating a new account. Part of the new account process involves doing setup of a domain. I started to setup service for “thereikipage.com” this way, but then used the dashboard to delete the service.
  2. I then went to the Dreamhost dashboard and tried to setup service that way. I specified the email address used for the newly created Cloudflare account. That gave me the failure shown above.
  3. I tried doing this a couple times, and may have tried with the other email address which I’ve been able to use to login to Cloudflare. But, as I said, the domain is not listed in that other account.
  4. I’m not about to post the email addresses publicly like this for obvious reasons
  5. I then used the Dreamhost dashboard to register two other websites, and that was successful. This means I’m able to use this account to register service for websites hosted on Dreamhost. But for some reason this fails for thereikipage.com

Eventually I tried to privately send a support request. I don’t like having had to post all these personal details publicly like this, but the response from the support request was that I’m required to post publicly to this forum. This is, to my thinking, wrong, since to properly describe the problem I have to divulge identification details, which is a bad idea on a public forum.

See ticket # 2251258 … @MoreHelp

No, it’s accurate

The domain was added to the account you are using here but nameservers were never confirmed and it was deleted about 8 days ago without ever being active. That seems to be accurate as well looking at securitytrails,

Perhaps you should contact them to see if they can shed any light on this? It sounds like you have two partner zones with dreamhost atm. Dreamhost is a partner. Ezoic is a partner. You can set up cloudflare with either of those partners, but not both.

3 Likes

Where is there another account at CloudFlare which covers my domain thereikipage.com? I wasn’t able to find such an account using email addresses that might have been used by me.

Yes, I’d started to set up something with Ezoic, but what does that have to do with CloudFlare now? The NS records for the domain point to Dreamhost DNS servers. The DNS records for my domain do not currently trace through Ezoic’s DNS servers, and therefore it should not have any impact on using Cloudflare with thereikipage.com. At least, that’s what I’m expecting.