Tried iubenda app, didn't work, tried SSL upgrade, didn't work, but got charged for them!

ssl

#1

I have been trying to get a response from support since May 6th:

  1. I installed the Iubenda app, immediately got a web service error shown in the cloudlfare dashboard, a cloudflare error, iubenda didn’t work on my site and no site was created at iubenda.com so I could manage the privacy policy…
  2. I choose to upgrade to an SSL dedicated certificate: it charged me, but then said error contacting certificate authority and that’s it.

Got charged twice for something that doesn’t work!
After a week I get this generic reply from billing: we have unsubscribed you for the iubenda app.

What kind of a service is this? If your product doesn’t work, you are supposed to fix it and offer a refund.

So I want a full refund for the items I purchased and don’t work, is that too much to ask?
I have a site where all upgrades work fine, so I’m sure it’s just a temporary bug, but this treatment of paying customers is below all standards.


#2

Update: upgrading to pro plan and trying SSL certificate upgrade again seems to work.


#3

This topic was automatically closed after 14 days. New replies are no longer allowed.