Tried everything, cache clearing seems to be unresponsive

caching

#1

Not sure if there is something going on with my cache configuration but it does not clear or bypass Cloudflare at all. This seems to be occurring since June 1st.

What I’ve tried

  • clearing server/application cache on my web server
  • clearing Cloudflare cache
  • enable development mode on Cloudflare

I’ve verified that the update file exists on the server by SSH - I’ve also verified the file is updated by using the server IP. But using the URL serves the old file no matter what. All of these lead me to believe something is currently going haywire on Cloudflare. Is anyone else experiencing issues?


#2

Do you have the correct IP address listed in Cloudflare DNS?

Give us an example of a URL for something that’s supposed to be updated.


#3

Thanks for the reply - yes the IP is correct on Cloudflare.

http://staging.importbible.com/js/footer.min.js

http://198.199.104.45/staging/js/footer.min.js

You’ll notice the IP version is starting with !function(e,t) not !function(A,e,t) via the URL with the domain.


#4

The path is different. If I take “staging” out of the IP address URL, I get the A,e,t


#5

The path is the correct, there is an htaccess file that writes the URL on the root folder to the staging folder. I’ve tested with a test file as well. Just wanted to add, this set up was working before recently.


#6

That doesn’t seem right. If I put “staging” into the path of the domain URL, I get the e,t


#7

The files are the same on your origin vs. what Cloudflare has cached.

diff <(curl -Is http://staging.importbible.com/js/footer.min.js --resolve staging.importbible.com:80:198.199.104.45) <(curl -Is http://staging.importbible.com/js/footer.min.js)

That includes the differences in headers (note no file differences).

diff <(curl -s http://staging.importbible.com/js/footer.min.js --resolve staging.importbible.com:80:198.199.104.45) <(curl -s http://staging.importbible.com/js/footer.min.js)

That is just the file differences, there are none reported.


#8

sorry I don’t think that is correct because my server ip will be same for staging and production therefore you will get the old file in production with the curl test if you are resolving the staging domain to the ip, am I wrong?


#9

staging.importbible.com and 198.199.104.45 should be identical, right? As far as we can tell, they are.


#10

Yes, that works but it seems to be caching the staging.importbible URL. I’ve added a test file to demonstrate the rewrite is working as intended.

http://staging.importbible.com/js/staging.js
http://198.199.104.45/staging/js/staging.js

staging.importbible.com should be the same as 198.199.104.45/staging - the subfolder is required


#11

Is the IP address of staging.importbible.com 198.199.104.45?


#12

yes it is, but the file sits under the sub-folder /staging


#13

Cloudflare is mimicking the structure of your server. The .js file in / does not match the .js file in /staging, as shown by @cscharff’s “diff” test and my observations.

If you want what’s in /staging to show up in /, you’re going to have to make changes on your server. I understand that you said it used to work, but this isn’t a Cloudflare issue.


#14

by that description, that means http://staging.importbible.com/js/staging.js should not work because it does not exist under the root - am I understanding what you are saying correctly?


#15

I’m not sure how your webserver is configured, but most map a hostname to a virtual directory. I think perhaps if you :grey: your record at Cloudflare and bypass Cloudflare’s proxy entirely you will see that this isn’t a caching issue but rather the structure of your webserver file hierarchy does not match what you believe it is and that the files you are updating are not the ones being called when a user requests them.


#16

thanks for the explanation, I’ll have to dig deeper and see what is going on. I think the folder structure is correct but it appears something else is intercepting the request for static files or something.


#17

This topic was automatically closed after 14 days. New replies are no longer allowed.