Transferring domain to Cloudflare - Stuck at 'Transfer in Progress'

Hi,

I’ve been tried, and failing, to transfer my .co.uk domain over to Cloudflare domains for the last week or so.
I submitted my request to transfer to Cloudflare originally on 10th June, after which it’s sat on the status message of ‘Transfer in Progress’.

I’ve confirmed that the IPS tag reads ‘Cloudflare’ as well as the nameservers are still pointed at Cloudflare.

I’ve tried cancelling the transfer (in case it had truly gotten stuck), but that fails too!
I have submitted a ticket with Cloudflare support (#2471756), but have heard nothing since I submitted it a week ago

Any ideas as to what’s going on?

As if by magic, the domain transfer completed after I posted this.
Thanks to whoever saw this!

.UK (and I assume .co.uk and its siblings) is a weird, problematic TLD. It took me several months and 20+ attempts to get mine to successfully transfer. I’ve seen several other threads of others having issues as well. Eventually it just works with no apparent explanation.