Transferred domain - infinite loop of redirects

I just transferred the domain for a friend’s non-profit from Google domains to CF. It worked previously and it’s just A records to the IP address of the host. The same records are in Cloudflare now but the website won’t resolve. When I check a redirect checker (I couldn’t paste the link here) it shows a 301 over and over and then it stops. The domain is livingbridges . org. I’ve tried the different encryption modes but it hasn’t resolved the issue yet. Any ideas?

If you pause cloudflare, does it work while paused?

On the zone, are there any Page Rules, Redirect Rules, Transform Rules or Workers Routes?

If not, what is the domain?

When I pause as you suggested, the site works. The domain is livingbridges . org, and I don’t see any rules configured for it.

Also, when I check the redirect checker with CF paused there are no redirects when I check https, and if I check http, there 1 that redirects it to https.

I see the opposite:

PS C:\Users\Erisa> curl -v
*   Trying [origin ip]:443...
* Connected to ([origin ip]) port 443 (#0)
* schannel: disabled automatic use of client certificate
* ALPN: offers http/1.1
* ALPN: server accepted http/1.1
* using HTTP/1.1
> GET / HTTP/1.1
> Host:
> User-Agent: curl/8.0.1
> Accept: */*
< HTTP/1.1 301 Moved Permanently
< Date: Sun, 24 Sep 2023 16:03:47 GMT
< Server: Apache
< Location:
< Content-Length: 238
< Content-Type: text/html; charset=iso-8859-1
<title>301 Moved Permanently</title>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="">here</a>.</p>
* Connection #0 to host left intact

Looks like the origin server is performing the redirect loop?


Interesting, I get the same with a curl command, but I was using a website to check redirects (wheregoes) and it shows none. I don’t have control of the site itself but from the curl it looks like it has a 301 redirect but just back to itself again?

Are you maybe using the Flexible SSL setting in Cloudflare?

If so, you should switch it to Full (strict).


Yep, I had tried, full, and none but seems like I somehow missed full/strict. Looks like it works now, thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.