Transfer of ORG domains not working

I have two domains currently at freenom.com. I’d like them to be transferred to CF registrar. Unfortunately the transfer for both of them fails with somewhat detailed error response “Something went wrong”!?
Both domains are in my CF profile with configured DNS servers set to CF’s addresses.
Both domains are unlocked and authorization code for both is filled correctly.
I have tried several times during 2 days with no luck. I have tried to use [email protected] but that is not available for the “Free plan”.
Does someone have any idea what could be wrong, because I’m all out of ideas?

What are the domain names?

Freenom WHOIS servers are not that reliable and many people are complaining about freenom services, cause freenom is mainly used for spam, malware domains ( .cf .tk ).

Please have a look here : What is the problem with Freenom (.tk .ml .ga …)? - Getting Started - Cloudflare Community

I also had a domain registered at Freenom, but had to move first to another registrar and after 90 days I could move it to CF.

Anyone else has an idea to help @todor ?

1 Like

I’d rather not share the domains publicly. Will try through another registrar…
Too bad CF’s support is not available for dealing with it’s own broken service.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.