Transfer-Encoding chunked disable

Hello there.
How i can force disable Transfer-Encoding = chunked hardcoded by CF from response?
Because in this case CF also removing Content-Length from response which needed for most of OpenID clients (at least Epic EOS client need that header). I tried:

  1. Set to server response Cache-Control=private/no-cache
  2. Compression disabled
  3. Add parameters with random values to my POST
  4. Set bypass by CF Cache/Page rules (by SLL/Cookie/Path)

Nothing helps.

Even in developer mode CF removing Content-Length and set encoding to chunked

Attaching CF response example