Traffic with Unknown Browsers, OS and None Referrer

Hi,
I am getting suddenly increase traffic with Unknown Browsers, OS and None Referrer. My domain is dailyinfotainment.com (on blogspot.com) and i am using a add domain where all of my images are stored which is cdn.dailyinfotainment.com (on wordpress)
Check following images:-


My current firewall rules are as following:-
Allowed Bots
(http.user_agent contains “Yandex”) or (http.user_agent contains “muckrack”) or (http.user_agent contains “Qwantify”) or (http.user_agent contains “Sogou”) or (http.user_agent contains “BUbiNG”) or (http.user_agent contains “knowledge”) or (http.user_agent contains “CFNetwork”) or (http.user_agent contains “Scrapy”) or (http.user_agent contains “SemrushBot”) or (http.user_agent contains “AhrefsBot”) or (http.user_agent contains “Baiduspider”) or (http.user_agent contains “python-requests”) or (http.user_agent contains “crawl” and not cf.client.bot) or (http.user_agent contains “Crawl” and not cf.client.bot) or (http.user_agent contains “bot” and not http.user_agent contains “bingbot” and not http.user_agent contains “Google” and not http.user_agent contains “Twitter” and not cf.client.bot) or (http.user_agent contains “Bot” and not http.user_agent contains “Google” and not cf.client.bot) or (http.user_agent contains “Spider” and not cf.client.bot) or (http.user_agent contains “spider” and not cf.client.bot)

Bad Browser challenge
(http.user_agent contains “” and not cf.client.bot)

As per log details, 90% of requests are for Addon domain cdn.dailyinfotainment.com which has images.

My question are:
Is this normal behavior for traffic with Unknown Browsers, OS and None Referrer ?

If ans is No of above Q, then are my firewall rules okay to deal with this situation ?

Does addon domain is causing this issue, should I shift images to to blogger (main domain)?

Is this situation causing invalid traffic in Adsense ?

Any help would be appreciated.

Thanks

This rule will trigger for anybody not .cf.client.bot because all User Agent Strings contain “nothing”. It needs to be equals [empty quotes].

The Unknown issue has come up before:

1 Like

thanks for your response. I have change code as per your guideline.

@janvitos Have you find solution to your AdSense Invalid traffic issue ?

This topic was automatically closed after 30 days. New replies are no longer allowed.