Traefik or Proxy Manager in Docker

Hi everybody.
I have a little bit problem, I hope I can write my problem and you understand it because my english ins’t perfect :slight_smile:
I have a DIY NAS what it’s running OMV 5 and I used to Portrainer in my docker containers.
I bought a domain(namecheap) what end is “choicedomainname.com” and I add for a FREE Cloudflare account.
I used to some containers : nextcloud, tranmission, pihole, netdata
I’m running a Linuxserver containers, and I use to a letsencrypt(Linuxserver) container and resever proxy method (sudomain conf file) and I accessed my containers the internet for exapmle: nextcloud.choicedomainname.com, tranimssion.choicedomainname.com, etc, etc
My router used to a port fowarding the letsencrypt container and I use this port: 80:90 and 443:450
In Cloudflare used to root domain, and cname domain and TXT items a DNS only mode/type
I 'm running a container of DNs updeter : ddlcient (linuxserver/ddclient)
Cloudflare setting :
SSL/TLS = flexible
Always us HTTPS : on
Minimum TLS: 1.2
TLS 1.3:ON
automatic HTTP rewrite: on
Opportunistic Encrypt: ON

This settings used to 3-4 mounths ago, but I want to change other solution: Traefik or Proxy Manager

Traefik:I read and I can doi it this review

I read this review and I change my settings:
Cloudflare:

  • DNS/TLS: FULL (but i’m working a Flexible that is my default choice)
  • All CNAME and root domain change DNS Only to Proxied
  • My router chenged the ports: 80:80 and 443:443 ( IP was my NAS IP)
  • I installed the traefik and my container add this label-s other container what is this review
  • I installed the DNS updater conrainer : oznu/cloudflare-ddns:

My solution:

  • this site (nextcloud, tranmission, pihole) is available or Error 521,522 error.
  • I’m wainting for a 1-2 hour but this problem wasn’t resolve.

Proxy Manager:I read and I can doi it this review
Cloudflare:

  • DNS/TLS: FULL (but i’m working a Flexible that is my default choice)
  • All CNAME and root domain change DNS Only to Proxied
  • My router chenged the ports: 80:80 and 443:443 ( IP was my NAS IP) and I try the dafault ports (80:8080, 443:443)
  • I installed the Proxy Manager and change email address and password.
  • I add a new proxy host this method:
    - Doamin name: transmission.domainname.com | http:// 192.168.50.XX : 9091 |Block Common
    exploids
    • SSL: Request a new SSL | Force SSL | HTTP/2 or not enable | email address added | I Agree
      the Letsencrypt Terms…

My solution:
failed authorization procedure (http-01): urn:ietf:params:acme:error:unauthorized :: the client lacks sufficient authorization :: invalid response from
or timeout or Internal server error.

Can you help me?

I am afraid that is slight off-topic for the forum here. You better try at community.containo.us for example. StackExchange might also be of help.

As far as Cloudflare is concerned, do not use Flexible as that is still insecure. Only Full strict is properly secure.

Make sure your site is working properly without Cloudflare and only then switch over to Cloudflare.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.