Total newbie needs assistance with redirect from owned domain to a DDNS domain

I’ve got a Google Apps domain (I’ll use the example of which I’ve added to my Cloudflare account, modified to use the Cloudflare nameservers so that’s up and running as far as I can see.

I have a dynamic DNS domain set up via my Synology NAS (I’ll use the example of with a LetsEncrypt certificate which in turn, has a reverse proxy set up so I can access things locally.

But I can’t figure out what/how to do this. I tried adding a 301 redirect on page rules with that set up, but it just doesn’t seem to work, just getting a page can’t be found.

Any help on where I’m going wrong would be very appreciated!

That’s not enough information for us to help. If you posted an unedited screenshot of the Page Rule, we can help.

As requested, the destination is a dynamic hostname which is hosted on my Synology, if I type that into a browser, it’s fine.

You don’t have a DNS entry for ‘home’. Here’s a great tutorial on how to properly set that up. TLDR: You need an “A” record for ‘home’ with an IP address of

1 Like

I’ve added @ and home as an A record to as per the tutorial:

But I couldn’t add www as there seemed to be one there already as a CNAME:

Ah, I bet Google gave you that www record for a website. If you don’t have a website, you can ignore that. Typically you would have @ and www pointing to the same place for a website, then something like your ‘home’ sub domain pointing somewhere else.

I do have a basic page set up on the root of the domain, nothing of use really. So at the moment, with that set up, the home sub domain doesn’t resolve properly? Do I need to wait it out for dns servers to update?

‘Home’ may take a few hours. A “not found” response is often cached for several hours by local DNS. The best you can do is go to and purge that hostname. If you use for your resolver, that will clear it up right away.

Amazing, that worked.

Is there a way to mask the fact that the user is typing in the .com address but instead is being redirected to the .me address?

Cloudflare does not do domain masking.

Is there an equivalent of what Cloudflare does, but does domain masking?

This topic was automatically closed after 31 days. New replies are no longer allowed.