Total confusion

First, all the Roofer sites worked before today.
Second, it all started when I added
Third, because the site showed an ERROR 521, I contacted Hostgator.
Fourth, the guy who I first spoke with had me create a new A record pointing to their IP. He had said to wait the propagation time and all would work.
Fifth, I waited and still get the above error.
Sixth, I called Hostgator back and spoke with a different guy who said the Name for the new A record needs to be changed to the domain name.
Seventh, I’m currently waiting on the propagation again.
Eighth, are you ready for this?
Nineth, all my other sites now are showing the same error 521.
Tenth and final, any suggestions?

A 521 is covered at Community Tip - Fixing Error 521: Web server is down and basically means your server refused the connection.

Are you sure you have the right IP address configured on Cloudflare? Would it be the one ending in 62?

I added the IP given from Hostgator.

Would you feel comfortable posting the address here?

Alright, that should be the correct address (you can remove the posting if you want).

In that case it would seem as if your host blocks Cloudflare’s addresses from connecting. Contact your host and have them check if they block Cloudflare.

1 Like

Though do you still have the same address configured for the domain you mentioned at Access a basic HTML file? as well?

I haven’t added that IP to any other sites

Are you sure? That IP responds for that other domain as well and you didnt object when I mentioned it within that thread.

My content is with Sparkzio ( and uses CF as its CDN. What do I need to add to the DNS for my content to show?

In that case the issue from the other thread still is not fixed, and furthermore you do not have a secure page as your server is without an SSL setup.

You’ll need to figure out what the correct IP addresses for both sites are, configure them, and make sure the SSL setup on all machines is in order.

All domains are at::

Then you need to configure that address (instead of the one you mentioned earlier) and you need to make sure you have a valid SSL setup on your server too. That will be also the reason why the domain in this thread does not work.

Make sure the server has a proper SSL configuration for both domains and actually responds on port 443. Right now neither is the case.

Where do I make sure the server has a proper SSL configuration for both domains and actually responds on port 443?

Are you the administrator of that server? If not, you need to contact your host. I am surprised the machine is not correctly configured in the first place, that is something one should be able to expect these days.

What do you mean about configuring that address?

You need to configure that address on your Cloudflare DNS screen. Not the address you mentioned earlier.

Can you give me an example of what it should look like?

For the DNS configuration or the SSL setup? The former is explained under #Tutorials when you search for DNS records.

Then this is the correct address and you need to make sure the server is actually configured for SSL.