Too many redirects when proxing domain

Hello,

We moved our hugo website to Cloudflare pages today. Everything works fine as can be seen here:

https://3946a117.funciton-com.pages.dev/es/

Custom domain is funciton.com

When the dns record is proxied the browser displays a “ERR_TOO_MANY_REDIRECTS”. Solution is to not proxy the dns record but wonder if there is smth missing?

index.html at https://3946a117.funciton-com.pages.dev/ redirects to funciton. but that redirection seems to exist on every page after the dns is proxied.

Any hints on whats missing/not working?

Thanks!

For me, all this URLs are working properly without any redirection error.
Please try again and report back.

Yes. Everything is working correctly now due to the dns proxy being off. Seems that when I switch it to be proxied it keeps redirecting. Its an issue that appears when the dns record is set to be proxy only.

Please turn it on again, so we can debug it, to solve the problem, instead of making a step backwards and unproxy.

Done. Issue is visible.

Thanks.

It’s the classical HTTP to HTTPS loop:

Would be interesting what:

  1. PageRules you use
  2. SSL Mode you use

Bad new also: it’s a 301 redirect, which is getting cached by the client.

2 Likes

Yes. It is getting cached. Have turned the proxy off again.

No page rules and ssl mode is off.

Thats, the problem. Please turn it to “Full (strict)” and turn on proxy again. It then should work.
Feel free to also activate the “Always use HTTPS” option.

2 Likes

Done! it is working now. Thanks! This won’t affect other dns records, right?

If you just changed one DNS entry this will not affect others. But I strongly recommend that you proxy all of them whichs protocolls allow to be proxied by Cloudflare.

Like I said: better fix problems then to conceal them :wink:
You’re welcome!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.