Too many redirects when enabling CDN

My origin server doesn’t do any kind of redirection and has a valid SSL cert for https

If I enable the CDN, even with a page rule like this:

*domain.com/*

SSL OFF;
AUTOMATIC HTTPS REWRITES OFF;
OPPORTUNISTIC ENCRYPTION OFF;

I stay stuck in a loop with cloudflare redirecting http to https and https to http.

Why?

What about “Always Use HTTPS”?

You’ve left out a lot of information, so we can only take wild guesses. Can you show a picture of the page rule? Or post the domain?

To see your origin SSL certificate you need to set the DNS record to :grey:. You won’t use Cloudflare’s CDN.

The correct configuration there, for me, is set SSL to Full (Strict), Always Use HTTPS to on, Automatic HTTPS Rewrites to on (it doesn’t hurt).

1 Like

I don’t want to force https. I want to serve both http and https…

The page rule I created is the one I said in the post… *domain.com/* with ssl off, automatic https rewrites off, and opportunistic encryption off.

I noticed that after removing ssl off from my page rule, it now left the loop…but http still redirect to https…

Still keep SSL to Full (strict) and then disable always use HTTPS. That is the only setting on Cloudflare (apart from a page rule) that can do the redirect. If that is set to off then the setting is on your server.

2 Likes

It’s still redirecting http to https. If I disable the CDN I can access http without redirects so it’s not my server.

I do have always use https enabled for this domain. But I don’t want that in this specific link only…

Then disable Alway Use HTTPS in that Page Rule. You can, it’s one of the options.

Just out of curiosity: why do you want HTTP as well?

There isn’t a always use https off page rule, the rule enables https not disable it…

Yeah, realized now… I guess you would have to go the other way around. Disable it in the Crypto tab and enable it on the paths/subdomains you need.

This topic was automatically closed after 14 days. New replies are no longer allowed.